Sepia Solutions Events and Messages
Sepia Solutions
Services
Software
Support
Menu Footer

Arbutus - Technical Support Page

Back to Top

Arbutus Analyzer, Server and ConnectPlus

Users with active Maintenance & Support can download the latest software releases free of charge. > Restricted download area.

Arbutus actively listens to it's users and continously improves the software suite by adding modifications and new features.
Please find below a selection of the recent enhancements.
Back to Top

Analyzer 6.2

Over 50 new or improved features that make it easier to access, analyze, and search for data, automate & schedule procedures, export results, notify stakeholders, and manage your licensing.

Alongside this 6.2 release, Arbutus is excited to launch ArbutusLearning - the new online learning portal. Get up to speed quickly and work at your own pace or refresh your Arbutus skillsets if you haven't been to training in a while. Access to ArbutusLearning will be made available to all of our supported customers and current subscribers at no additional charge.

Analyzer V6.2, as released in January 2018, includes the enhancements listed below and more.
  • ArbutusConnect

    A suite of new data connectors that support the most common data sources our customers work with (Active Directory, Excel, MySQL, SQL Server, etc.).

  • Speed time to visualization

    Export directly to Tableau using the Tableau TDE format.

  • Arbutus SmartApps

    Access to over 60 SmartApps automatically as part of the install.
    Additions, improvements and online training content via ArbutusLearning.

  • Expanded Fuzzy Matching

    Improve audit findings with meaningful fuzzy matches – added functionality for Dice's Coefficient.

  • Arbutus ODBC Explorer

    Preview and format your data prior to downloading with this fullfeatured interactive app - query and join any ODBC/SQL data.
    • No need for table definition
    • Ability to select any combination of tables
    • Join multiple tables
    • Preview result in a window
    • Specify filtering on Sort criteria
    • View data in hex, for problem situations
    • Automatically create appropriate command syntax when satisfied

  • Arbutus QuickStats

    See the total, average, and count on the status line by simply highlighting a range of cells in your view.

  • Excel related

    • Improved formatting so datetime fields display in Excel better when exported from Analyzer
    • Added a progress dialog when exporting to Excel XLSX
    • Fixed a bug where exporting to a file with multiple sheets updated the formatting on ALL sheets

  • Server

    • Added support to restrict files from being moved from the server (avoid local storage on PC)
    • Server profile dialog now can have 2 servers to connect with (i.e. internal and external IP)
    • ODBC source data is automatically compressed when flattened

  • Scheduling

    • Server Profile information is now only written once for each unique user scheduling jobs, easing password maintenance
    • Server Profile information for each unique user gets updated automatically with password updates
    • Added support for users with security rights to edit/delete scheduled jobs submitted by others
    • Added support to kill orphaned scheduled jobs on the server

  • Managing activations

    • Added support so users can see all of the activations for their key/code
    • Added support so users can delete activations from within Analyzer

  • Procedures / scripting

    • Added support to DIALOG command to allow chosen table to be immediately opened/used
    • Added support to select multiple items from a project item dropdown
    • Added support for using macros with variable arrays from project items
    • Added support for allowing nested macros

  • Data definition wizard

    • Added several new connectors to allow for easier data access to common data sources
    • Added support to read HTTPS web URLS (server only)
    • Added speed search for ODBC fields
    • Added a check box to check for available space when flattening data from ODBC
    • Server-based ODBC tables now default to flatten the data (like local ODBC does)

  • (Project) Overview

    • Added support to update the local project folder contents via F5 or right-click
    • Added a right-click "Open as Secondary" for tables
    • Performing a block delete from the expanded Overview will immediately update the Overview

  • Commands

    • Improved NOTIFY so it will work with SSL and all email protocols
    • Improved the RELATION command so related tables can be shared across different regions/languages
    • Improved CROSSTAB so it now supports row and column totals as well as drilldown
    • Added support for OPEN to now have an additional PASSWORD parameter

  • Functions

    • Added SIZE to tell how many items are in a variable array
    • Added DICECOEFFICIENT
    • Changed EOMONTH to return only the data found in the source data (no time component returned now if the source data was just a date)

  • SAP

    • SmartLink can now read tables of any width without needing to create a new RFC
    • SmartLink now compresses data imported from SAP
    • SmartLink can now join tables
    • SmartLink can now process in background mode
    • SmartLink automatically retrieves background jobs when processing is complete
    • SmartLink can now filter on time fields

  • Miscellaneous

    • ArbutusLearning – new Online Learning Portal
    • Improved how Workspaces are added and edited
    • Improved the ACL Project Converter
    • Preview data from ODBC sources without the need for a table definition
    • Added a warning message when the project is already in use
    • Added SmartApps automatically as part of the install
    • Added Back and Next arrow buttons to the button bar that allows tables to be re-opened based on the order in which they were opened
    • Added an editable area to enter an alternate code page value in Table Options tab or Edit Table Layout
    • Added the count, total and average for highlighted numeric "cells" in the view
    • Command dialog appears on the primary screen for those with multiple monitors

> Review the "What's new in Analyzer Version 6.2" PDF document for details.
Back to Top

Analyzer 6.1

Analyzer V6, as released in April 2017, includes the enhancements listed below and more.


  • Installation

    • Silent install
      For sites that have a large number of users, we now support using MSI install so multiple users can automatically have the software installed at one time.
    • Multi-language install
      The new install supports choosing all available languages supported by Analyzer and the activation code supports using any language (previously activation codes were language-based).
    • Auto-deactivation
      Uninstalling the software will release the activation from the Arbutus database so the software can be installed on a new machine without intervention from Arbutus.

  • Commands

    • SORT now support RAM > 4GB
      We now support utilizing more than the 4GB maximum RAM that handicaps 32-bit applications so you can now utilize more of the available RAM on your computer, improving the speed of sorting large files.
    • EXPORT to Excel using OpenExcel
      Importing and Exporting to/from Excel no longer will default to using 32-bit ODBC. This new method of getting data into Analyzer from Excel and to Excel from Analyzer improves issues encountered with ODBC such as: records with disparate data types, data in records lower in the file that are longer than 255 characters, inability to handle various field names and the annoying blank Sheet1 created when exporting to XLSX file types.
    • EXPORT to JSON
      We now support exporting data to Java Script Object Notation for use by other applications/users.
    • RELATIONS warns if key lengths differ
      Analyzer now warns if the parent and child keys differ. Analyzer does not force the keys to be the same; the parent key can still be shorter than the child key, but we certainly suggest that they should be the same length to avoid unexpected results.

  • Log File

    • Save log to HTML
      For users who want to print tabular data and retain the look/feel and also for those who require that the log be saved as a PDF, Analyzer now supports the ability to save the log file as an HTML file and then you can print the results to a PDF or create a hard copy for non-Analyzer users

  • New functions

    • REGEXFIND()
      This has been added to be compatible with any old ACL scripts.
    • REGEXREPLACE()
      This has been added to be compatible with any old ACL scripts.
    • WORKDAY()
      This function allows the user to determine whether a particular date is a "work day" or not.
    • UNICODE()
      This function allows an easy method for converting ASCII values into Unicode format for use when appending data.

  • Improved functions

    • DOW()
      This function now returns a 0 for any blank dates encountered versus returning "1".
    • CDOW()
      This function now returns a blank for any blank dates encountered versus returning "Sunday".

  • View

    • Alternate row shading
      Like Excel, you can now have various rows shaded to be a different color to add some visual context to your data.
    • Import JSON data
      Analyzer now supports reading Java Script Object Notation data.
    • Print image: leave first selected field highlighted
      For any new record type definition Analyzer now leaves the first selected field highlighted, so that you are better able to select appropriate record definition criteria.

  • Interface

    • Speed search in edit table layout
      This allows for quicker access to fields when the table layout contains many fields.
    • Speed search in F2 dialog
      This allows for quicker access to fields when the table layout contains many fields.
    • Copy multiple project items
      Previously, if you wanted to copy multiple table layouts or procedures from another project, you had to copy each file in separately. Now you can bring in the objects all at once using standard Ctrl and Shift keys.
    • Menu icons
      By adding a smaller version of the command icon beside the command on the menu, the user can more easily associate the icon with the command.
    • Improved table properties
      Enhanced the properties to include whether or not a server data file is compressed so users have an easier way of determining the attributes of the data file being read.
    • Larger F2 and F4 dialogs
      Improved the interface so that users working with a large list of objects can see these more clearly.

  • Added browser-based server access

    • WebConnect is the new client that runs from your browser.
      This is intended for large user communities to easily submit jobs from anywhere, without requiring any Analyzer experience or software installed. It is configured to access the same shared folders that you use with Analyzer, but since the connectivity is all through your browser, you don’t need to install Arbutus components on the local computer. All shared folder maintenance is handled through Analyzer, in the normal way.
    • Webconnect displays the shared folders in the same manner as Analyzer, including sub-folders. The initial version will let you run scripts and view tables that are in server shared folders. Normally the scripts are "canned", and you pass in parameters before the script starts. Beyond that, there is even limited interactivity, as a script can have one (just one) standard DIALOG command, for additional script parameters.
      Table viewing is best for smaller tables, due to the constraints of browser-based user interface.
      Results are typically emailed to the user, but you can also configure scripts so the user can immediately look at tabular results in a private output area.

  • SmartLink

    SmartLink is a new interface that allows users to directly access SAP tables. Users can perform table joins of the SAP tables as part of the import process without needing to bring in the individual tables into Analyzer first. This interface works with existing ACL DirectLink code but has built-in added functionality. Improvements over ACL DirectLink available upon request.

  • Changes to existing functionality

    • If a new project is created with the same name as the folder users are no longer prompted to create a folder.
    • If a corrupted project is encountered, it now gets automatically fixed and a message is provided.
    • The cursor does not highlight the view filter once it has been set.
    • The objects deleted in a procedure are no longer placed in the recycle bin.
    • The dropdown for the character set in Edit Table Layout is UTF16 for Unicode SAP data.

  • and more ...

    Please refer to the full "What is new" documentation for details.

> Review the "What's new in Analyzer Version 6.1" PDF document for details.
Back to Top

Analyzer 6.0

Analyzer V6, as released in November 2015, includes the enhancements listed below and more.

  • Full Unicode Support

    This release now offers full Unicode support (UTF8 and UTF16) for all languages, as well as full keyboard support for Unicode with the Data Definition Wizard, the Command Line in the Command Log, the Procedure Editor, and more.
    Foreign file names (such as those in Chinese or Cyrillic) are now also supported.

  • Button Bar

    The redesigned icons on the Button Bar are now larger, facilitating at-a-glance recognition.
    Users can also make the icons large or small via: Tools > Options > Interface.

  • Project Overview

    Overview Explorer:
    You can now expand the Overview with a click, to allow easy object management, such as mass deletion or movement, as well as renaming of project items from within a project folder or from the project root.

    Arbutus Repository:
    You can now use Analyzer as a repository for documents from other applications.
    Documents from other applications (such as Excel) can now be launched directly from Analyzer, with just a click.

  • and more ...

    Please refer to the full "What is new" documentation for details.

> Review the "What's new in Analyzer Version 6.0" PDF document for details.
Back to Top

Analyzer 5.7

This release of Arbutus Analyzer, published in July 2014, includes too many enhancements to list them all here.
The complete list of enhancements can be downloaded here. The top 5 enhancements include:

  • SmartLink for SAP® ERP Software Tool
    The new SmartLink for SAP® ERP software tool reduces the time, effort, and costs typically associated with SAP data access easily. Analyzer users can now use Arbutus Windows Server to connect to, filter, and import data from SAP ERP systems.
  • Improved SUMMARIZE command
    With Analyzer 5.70, you can output SUMMARIZE results to screen with various hyperlinks for drill-down to view the relevant records. You can also Summarize on numeric fields in addition to the already supported character and date fields.
  • Improved STATISTICS command
    When performing STATISTICS on a datetime field, you can now view the number of weekend dates encountered. The weekend count is a hyperlink that can be clicked on to drill-down to view the relevant records.
  • New functions
    - LFILL() : Will add leading characters to an existing string or numeric value.
    - SINE() : returns the numeric sine of an angle that is expressed in radians
    - COSINE() : returns the numeric cosine of an angle that is expressed in radians
    - TANGENT() : returns the numeric tangent of an angle that is expressed in radians
    - ASINE() : returns the numeric arc sine of an angle that is expressed in radians
    - ACOSINE() : returns the numeric arc cosine of an angle that is expressed in radians
    - ATANGENT() : returns the numeric arc tangent of an angle that is expressed in radians
    - RADIANS() : returns the numeric radians for an angle expressed in degrees
  • Improved functions
    - An optional parameter was added to the ALLTRIM(), LTRIM(), and TRIM() functions to specify one or more leading and/or trailing characters that should be removed in addition to blanks.
    - The ISBLANK() function now supports physically defined date fields (excluding packed dates).
    - The SIMILAR() function now removes leading zeros in character fields to ensure better string matching.
Back to Top

Analyzer 5.6

This release of Arbutus Analyzer, published in April 2014, includes too many enhancements to list them all here.
The complete list of enhancements can be downloaded here. The top 10 enhancements include:

  • New SQL command
    In Analyzer V5.6, support for SQL has been extended with the new SQL command. This allows you to embed SQL Select queries directly into your Arbutus procedures or scripts. If you already know and use SQL, you can take advantage of the capabilities offered by SQL and run any queries from Arbutus, to get the benefits of both worlds.
  • Monitoring/Scheduling Admin Tool
    The new Monitoring/Scheduling Admin tool, which, when used with the Arbutus Enterprise Edition, supports viewing and managing all scheduled scripts for individuals, teams, and departments
  • Enhanced Protect Program
    The Protect program is no longer a separate application. It can now be used from within Analyzer to prevent unwanted viewing and/or edits of your scripts.
  • Improved PDF Converter
    The Arbutus PDF Converter has been enhanced to provide even better conversion accuracy and reliability.
  • Enhanced Integration with Windows Explorer
    You can now drag-and-drop any data file from Windows Explorer into Analyzer to automatically start the Data Definition Wizard. Analyzer will access the file and launch the Wizard with the correct File Format selected.
  • New functions
    GOMONTH() function calculates the date, in months, from the specified date.
    TODAY() function returns today’s date, which is particularly useful for real-time applications.
    NOW() function returns the date and time right now, also useful for real-time applications.
  • EXPORT command
    The EXPORT command has been enhanced in three significant ways:
    You can now use the Append option when exporting via ODBC to relational tables.
    When exporting columns containing UNICODE data to Excel, Access, or via ODBC, the data will be exported as Unicode.
    You can now export fields longer than 255 to Excel (max length 32760 bytes)
  • Variables window
    The new optional Variables Window will display the current values of all existing variables. In addition to showing the values, the window automatically highlights any values that have changed since the last command, so you can be sure to see the changes.
    The Variables Window (below) is particularly useful when running scripts in Step Mode to assess the changing values of all variables at each step in the script. The Variables Window also allows constant monitoring of variable values.
  • Procedure editing features
    The Procedure Editor now features unlimited undo options for easier corrections of typos or deletions.
  • Video tutorials
    Video Tutorial links have been added to the main Help page of Analyzer. Video tutorial topics include: “Defining Relational Database Tables in Analyzer”, “Scheduling”, “Procedure Debugging”, “Fuzzy Duplicates”, and more.
Back to Top

Analyzer 5.5

This release of Arbutus Analyzer, published in May 2013, includes too many enhancements to list them all here.
The top 10 enhancements include:

  • Procedure scheduling
    Server-based procedures may now be scheduled from the Overview with a right-click. There is no need for a separate product or user interface. Scheduling options range from Now to Monthly. Also, depending on the test, results can be 3-10 times faster than Fuzzydup. We have test files you can use, if you don’t have appropriate data.
  • Duplicates Same-Same-Near and Same-Same-Similar
    You can now look for fuzzy duplicates within a file using the Duplicates command. The ability to specify “Same” keys makes the command dramatically more powerful than that other company’s Fuzzydup command. This allows you to, for example, test for same vendor, same date, similar invoice number, as well as process millions of records in seconds.
  • Procedures are now independent of your individual preference settings
    Setting changes made by a procedure are automatically reversed on completion. Also, the new Set Default command ensures “factory” settings are in place for your procedure, which you can then modify as required.
  • SIMILAR()
    This new function complements the fuzzy NEAR() function. SIMILAR() is also fuzzy, but is specifically designed to ignore differences due to visually similar characters (such as I vs. 1 or 0 vs. O). It also allows testing for transpositions of digits in numbers and dates.
  • LISTFIND()
    This function allows you to easily scan for an unlimited list of words in a file or fields. This is particularly powerful for purchase card analyses.
  • Auto-loading Workspaces
    You may now refer to Workspace fields directly in any expression (including Views and computed fields) using the familiar x.y format, without the need to first activate the Workspace. In this case, x is the name of the workspace and y is the field name. When using this syntax, the Workspace is automatically loaded.
  • Copy and Paste fields
    You may now move field definitions between tables with a simple copy and paste in Edit Table Layout. This eliminates the need for awkward uses of Workspaces and applies to all field types, including computed fields.
  • Extract View
    This allows you to easily extract the data showing in the current view, in the same manner as previously available for Export.
  • Multi-Parameter Functions
    A number of functions (e.g., Maximum()) have been extended to allow any number of parameters. These functions can also take a variable array as a parameter, and will process the entire set of values as if they were individual parameters.
  • Sort and Index
    The algorithm has been revised, improving speeds significantly.
Back to Top

Analyzer 5.4

This release of Arbutus Analyzer, published in July 2012, included too many enhancements to list them all here; please review the readme.txt file for a full list of enhancements.
The main enhancements include:

Developing automations
  • Coloured syntax (commands, comments and key words) in the Procedure Editor
  • Line numbers to the Procedure Editor
  • Support for break points in code
  • Step mode (line-by-line execution) of code for debugging
View
  • Cell background/text colours according to user-defined conditions
  • Computed field column headings in a user-specified colour
  • Related fields column headings in a user-specified colour
User Interface
  • Added a Close All right-click item for tables
  • All refreshable table layouts can now be re-linked to new source files using "Link to New Table Data"
  • Table Properties now show the source file information for refreshable data sources
  • Refreshable tables can now be displayed with a vertical blue strip
  • Tables with relations can now be displayed with a vertical green strip
  • Procedures in Shared Folders are always displayed through the new Applications menu
Import
  • IMPORT now supports USERID and PASSWORD parameters
  • IMPORT now supports editing the command from the command line to add/remove fields
  • IMPORT now supports editing the command from the command line to add ad-hoc expressions
  • SQL import syntax is now written to the command log
Commands
  • VERIFY now allows users to exclude validation of empty field values
  • JOIN now support auto-harmonization of the join keys
Functions
  • New functions: Year(), Month(), Day(), Hour(), Minute(), Second()
  • New functions: NtoD(), NtoT()
  • New functions: Cmon(), EOMonth()
  • New function: SORTNORMALIZE()
  • Improvements to STRING()
  • Improvements to NORMALIZE()
  • Improvements to Improved ARRANGE()
Command Log
  • Improved logging to update the log when data has been refreshed
  • Improved logging to include when fields are created, edited or deleted via the Edit Table Layout
General
  • Utility for manual activation of software
  • Added enhancement to support Ctrl+G in Edit Table Layout to quickly locate a specific record number
  • Added enhancement to support Page Up/Dn keys in Edit Table Layout to better navigate large files
Back to Top

Analyzer 5.3

This release of the data analysis and ETL tool Arbutus Analyzer, published December 2011, features following improvements:

Import / Export capabilities
  • Import: allow the SQL join of more than 5 tables
  • Export: export directly to an ODBC table
Variable arrays
  • Implemented support for variable arrays
  • Save content of field to variable arrays
  • Improved DIALOG command to accept arrays for drop-down lists
Functions
  • New Function: NORMALIZE()
  • New Function: ARRANGE()
View
  • Display negative values in red
  • Auto-size View columns by double clicking on right edge
  • Improved the appearance of the view
  • Improved filter processing and speed
Table layout
  • Table layout now reads entire file
User interface
  • Check (online) for updates
Back to Top

Analyzer 5.2

This release of the data analysis and ETL tool Arbutus Analyzer, published May 2011, features following improvements:

  • Enhancement to allow multiple primary tables at the same time in the view
  • Added new join type, SQL, to facilitate true sql many-to-many join
  • Enhancement to support JOIN on non-character keys
  • Enhancement to include Venn diagrams for the various join command options
  • Enhancement to have a REPLACE for quick filters instead of just AND and OR
  • Enhancement to SPLIT() to allow you to pull segments in reverse order
  • Added new function, NEAR(), that performs a "fuzzy" comparison between two fields
  • Added new function, LEFT(), that acts like substring
  • Added new function, RIGHT(), that is the same as LAST()
  • Added new SmartSearch capability from the view similar to "Google searches"
  • Enhancement to replace CRLF with spaces if found in fields of relational database tables
  • Enhancement to auto-recreate the flat file, in the event that it is missing
  • Enhancement to Extract record so the current view is used instead of creating a new view
  • Enhancement so the wizard better detects time fields
  • Enhancement so the wizard better detects character fields with leading zeros
  • Enhancement to DISPLAY command so you can write the contents to a data file
  • Enhancement to allow users to select only certain XML data to define using a tree view
  • Enhancement to allow users to define physical fields for delimited files
  • Enhancement to flatten files via the wizard to the current folder and not to the project root
  • Enhancement to add a quotes button in the expression builder
  • Enhancement to put the Edit Command icon back on the command line
  • Enhancement to support using variables for all functions that use a constant value
  • Changed defaults for radio buttons and checkboxes to previous values
Back to Top

Analyzer 5.1

  • Enhancement to support longer user IDs for Windows Server users running Windows 7 OS
  • Enhancement to speed up the definition process when defining very large files
  • Enhancement to support reading Excel & Access 2007 files via local DDW
  • Enhancement to buffer data exported to new Excel/Access
  • Enhancement to support exporting to alternate Excel pages and Access tables
  • Enhancement to write out the full path for local exports
  • Enhancement to reinstate local shared folders
  • Enhancement to increase the maximum string size from 1024 to 10000
  • Enhancement to Export command to support MS Access
  • Enhancement to Export command to support more recent MS Excel than 2.1
  • Enhancement to support IMPORT DBASE versus just defining via wizard
  • Enhancement to hold a long table layout name (maximum of 127 characters)
  • Enhancement to support IMPORT DELIMITED versus just defining via wizard
  • Enhancement to support IMPORT FILE versus just defining via wizard
  • Enhancement to support IMPORT EXCEL versus just defining via wizard
  • Enhancement to support IMPORT XML versus just defining via wizard
  • Enhancement to directly relink existing layouts to new Excel and XML source files
  • Enhancement to wrap long commands in the Procedure window
  • Enhancement to enable users to validate their SQL WHERE clauses
  • Enhancement to support field level decimal characters
  • Enhancement to hyperlink invalid dates for Statistics command
  • Enhancement to support datetime field type in Print Wizard
  • Enhancement to support datetime examples for AM/PM time formatting
  • Enhancement to increase object length to 127 characters instead of 31
  • Review the readme.txt file in installation package for a complete overview.
Back to Top